Sametime através do Pidgin – corrigindo problema de conexão no Ubuntu Xenial (libmeanwhile1)

Bem galera, trabalho em uma empresa onde é utilizado o famoso (ou nem tanto) notes e com o linux, tive algumas dificuldades em encontrar o cliente linux para o serviço de mensagem instantânea do mesmo, chamado de Sametime.

Utilizando a distro Ubuntu Xenial, descobri que o pidgin tem suporte ao protocolo do mesmo, porém não conseguia nunca logar. Efetuei umas pesquisas pela internet e vi que tem um probleminha com a libmeanwhile1 que na release Xenial, está na versão 1.0.2-7. Também encontrei uma possível solução que seria fazer o downgrade desta lib para a versão 1.0.2-4.1 porém não encontrei em lugar nenhum o “como fazer” (How to). Bem, com isso, mãos a obra e vamos nos virar para descobrir.

Na verdade nunca tinha precisado fazer algo do gênero no ubuntu, só em redhat/centos/fedora, que é relativamente simples.

Bem, vamos parar de papo e vamos ao que interessa de verdade.

Vc terá que adicionar algumas linhas no seu apt para que possa ter acesso a essa lib e também a todos os pacotes de uma release antiga, no caso a Trusty Tahr (14.04.5 LTS).

 

Primeiro passo, instale o pidgin.

# apt-get install pidgin pidgin-plugin-pack -y

Agora criamos o source para os pacotes da release Trusty Tahr.

# echo -e “deb http://mirror.globo.com/ubuntu/archive/ trusty main restricted \n \
deb http://mirror.globo.com/ubuntu/archive/ trusty universe \n \
deb http://mirror.globo.com/ubuntu/archive/ trusty multiverse” >> /etc/apt/sources.list.d/trusty.list

Atualizamos a listagem de pacotes no SO

# apt-get update

Para verificar que está tudo ok e que o pacote que vc deseja já está disponível para instalação, rode o comando abaixo para ver.

# apt-cache showpkg libmeanwhile1

Irá aparecer uma lista como essa…

Package: libmeanwhile1
Versions:
1.0.2-7 (/var/lib/apt/lists/mirror.globo.com_ubuntu_archive_dists_xenial_universe_binary-amd64_Packages)
Description Language:
File: /var/lib/apt/lists/mirror.globo.com_ubuntu_archive_dists_xenial_universe_binary-amd64_Packages
MD5: 82e65bea7e1388bd4ffee62b6cc57363
Description Language:
File: /var/lib/apt/lists/mirror.globo.com_ubuntu_archive_dists_xenial_universe_binary-i386_Packages
MD5: 82e65bea7e1388bd4ffee62b6cc57363
Description Language: en
File: /var/lib/apt/lists/mirror.globo.com_ubuntu_archive_dists_xenial_universe_i18n_Translation-en
MD5: 82e65bea7e1388bd4ffee62b6cc57363
Description Language:
File: /var/lib/apt/lists/mirror.globo.com_ubuntu_archive_dists_trusty_main_binary-amd64_Packages
MD5: 82e65bea7e1388bd4ffee62b6cc57363
Description Language:
File: /var/lib/apt/lists/mirror.globo.com_ubuntu_archive_dists_trusty_main_binary-i386_Packages
MD5: 82e65bea7e1388bd4ffee62b6cc57363

1.0.2-4.1ubuntu1 (/var/lib/apt/lists/mirror.globo.com_ubuntu_archive_dists_trusty_main_binary-amd64_Packages) (/var/lib/dpkg/status)
Description Language:
File: /var/lib/apt/lists/mirror.globo.com_ubuntu_archive_dists_xenial_universe_binary-amd64_Packages
MD5: 82e65bea7e1388bd4ffee62b6cc57363
Description Language:
File: /var/lib/apt/lists/mirror.globo.com_ubuntu_archive_dists_xenial_universe_binary-i386_Packages
MD5: 82e65bea7e1388bd4ffee62b6cc57363
Description Language: en
File: /var/lib/apt/lists/mirror.globo.com_ubuntu_archive_dists_xenial_universe_i18n_Translation-en
MD5: 82e65bea7e1388bd4ffee62b6cc57363
Description Language:
File: /var/lib/apt/lists/mirror.globo.com_ubuntu_archive_dists_trusty_main_binary-amd64_Packages
MD5: 82e65bea7e1388bd4ffee62b6cc57363
Description Language:
File: /var/lib/apt/lists/mirror.globo.com_ubuntu_archive_dists_trusty_main_binary-i386_Packages
MD5: 82e65bea7e1388bd4ffee62b6cc57363

Reverse Depends:
libmeanwhile-dev,libmeanwhile1 1.0.2-4.1ubuntu1
libpurple0,libmeanwhile1 1.0.2
kopete,libmeanwhile1 1.0.2
libmeanwhile1:i386,libmeanwhile1
libpurple0,libmeanwhile1 1.0.2
libmeanwhile-dev,libmeanwhile1 1.0.2-7
libmeanwhile1:i386,libmeanwhile1 1.0.2-7
libmeanwhile1:i386,libmeanwhile1 1.0.2-7
libpurple0,libmeanwhile1 1.0.2
kopete,libmeanwhile1 1.0.2
Dependencies:
1.0.2-7 – libc6 (2 2.14) libglib2.0-0 (2 2.24.0) libmeanwhile1:i386 (35 1.0.2-7) libmeanwhile1:i386 (38 1.0.2-7)
1.0.2-4.1ubuntu1 – libc6 (2 2.14) libglib2.0-0 (2 2.24.0) libmeanwhile1:i386 (32 (null))
Provides:
1.0.2-7 –
1.0.2-4.1ubuntu1 –
Reverse Provides:

Aqui é que acontece a “mágica”. Você vai indormar ao sistema que vc quer o pacote de uma release específica, utilizando a opção -t e depois determinar a versão do pacote que você deseja.

# apt-get install -t trusty libmeanwhile1=1.0.2-4.1ubuntu1 –allow-downgrades -y

E agora, para não acontecer nenhum acidente e o sistema fazer o upgrade do pacote sem que você queira, vamos marcar ele para não ser atualizado.

# apt-mark hold libmeanwhile1

Feito esses pequenos passos, você vai conseguir acessar o sametime através do pidgin ao invés de ter que usar o cliente do sametime.

Agora é só correr para o abraço e utilizar!!!!

>>>>>>>>>>>>>>>>>>>>>>>>>>><<<<<<<<<<<<<<<<<<<<<<<<<<<

Espero que com isso possa ajudar outras pessoas assim como me ajudou.

Grande abraço e até a próxima!

Mario Neto